Hello from Canada - Maserati Levante Forum
Reply
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 05-08-2017, 07:31 PM Thread Starter
Junior Member
 
Join Date: Feb 2017
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Hello from Canada

Well i just recived my Levante s fully loaded, with sport package the car is amazing handling and driving experience is on point,
but here is the worst part after traveling around 950 km in less than 3 days of owning it the Front park sensors not working need service message appeared, I contacted the dealer and they will call me tomorrow to see what to do.
Puls i had the dealer install 3m stonegard for the front and ceramic pro exterior and interior

Any ideas for this failure?

Any Qs about the car im happy to help.
Abdul Mo is online now  
post #2 of 11 (permalink) Old 05-08-2017, 10:02 PM
Senior Member
 
Join Date: Sep 2016
Location: NYC and RI
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
We want pictures. I bet the stongaurd install is the cause of your sensor problem

BTW, are radar detectors legal in Canada? I sure hope so!
Bengoshi is offline  
post #3 of 11 (permalink) Old 05-08-2017, 10:34 PM Thread Starter
Junior Member
 
Join Date: Feb 2017
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Sadly it's illegal in ontario but i know that in some other provinces it's legal.
Still can't understand how they would damage the sensor with the installation but i'll take everything in consideration.

Here some photos blue emozione and red with carbon inserts.
Attached Images
File Type: jpg IMG_1992_1494296809378.JPG (102.9 KB, 22 views)
File Type: jpg IMG_1994_1494296905497.JPG (149.2 KB, 22 views)
File Type: jpg IMG_1993_1494296942657.JPG (117.6 KB, 16 views)
Abdul Mo is online now  
 
post #4 of 11 (permalink) Old 05-09-2017, 12:25 PM
Senior Member
 
Join Date: Sep 2016
Location: NYC and RI
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Nice. BTW, I notice the SQ4 badge on yours. Is that Canada only? There's no way to tell mine is an S here, I always thought that was strange. Or is that just new?
Bengoshi is offline  
post #5 of 11 (permalink) Old 05-09-2017, 05:05 PM Thread Starter
Junior Member
 
Join Date: Feb 2017
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Oh yeah that true i did notice it, i think the earlier production only that didn't have them not sure about the US production
Abdul Mo is online now  
post #6 of 11 (permalink) Old 05-09-2017, 05:30 PM
Junior Member
 
sharkrng's Avatar
 
Join Date: Jan 2017
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Quote:
Originally Posted by Bengoshi View Post
Nice. BTW, I notice the SQ4 badge on yours. Is that Canada only? There's no way to tell mine is an S here, I always thought that was strange. Or is that just new?
You can get the SQ4 badge from Maserati parts department, at least I did about 2-3months after I got my Levante
P/N 670101231 $34.80


Last edited by sharkrng; 05-09-2017 at 05:31 PM. Reason: typo
sharkrng is offline  
post #7 of 11 (permalink) Old 05-09-2017, 11:46 PM
Junior Member
 
Join Date: Mar 2017
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Quote:
Originally Posted by sharkrng View Post
You can get the SQ4 badge from Maserati parts department, at least I did about 2-3months after I got my Levante
P/N 670101231 $34.80



Oh goodie, I can make my non-S an S now. LOL


ACMTEXAS is offline  
post #8 of 11 (permalink) Old 05-10-2017, 07:34 AM
Senior Member
 
Join Date: Sep 2016
Location: NYC and RI
Posts: 110
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
I spoke to the guy in my Mazerati shop about ordering the badge for my S. He said "I remove all my badges, I don't know why you would want to put a new one on." Mine is an S. What would you do?

My wife will probably kill me if I put it on there, but it has always driven me crazy that there is nothing external to distinguish the S in anyway, unless you read the window sticker sitting in my glove box
Bengoshi is offline  
post #9 of 11 (permalink) Old 05-12-2017, 07:49 AM
Member
 
dabubbs's Avatar
 
Join Date: Sep 2016
Location: Denver, CO
Posts: 94
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
The badges are showing up on vehicles in the US with later production dates. Not sure why the earlier production vehicles didn't get them. Also, welcome, and congrats on that gorgeous ride! I'm curious if your 3M wrap will be the cause of the sensor issue, or if it's truly a physical problem.
dabubbs is offline  
post #10 of 11 (permalink) Old 06-13-2017, 02:53 PM Thread Starter
Junior Member
 
Join Date: Feb 2017
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
(Thread Starter)
Update: one of the front sensor was dead, plus i made them redo the stone guard because it started to peel from some corner and that took them two weeks to do, waiting for the parts was the worst part.
Abdul Mo is online now  
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome