Maserati Levante Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
2017 Levante. Drove 20 miles today, parked the vehicle in my garage for 15 mins and then attempted to start. The Vehicle just would not start. The vehicle is only 8 months old 12,000 miles. It makes a clicking noise however it won't crank. ITS DEAD. No warning just happened all of a sudden. Very frustrating. Had it towed at my expense to the Maserati Dealer. When i called the dealer they stated they have not heard of this issue. However it seems quite common if you read the forum. Will wait to see what they find tomorrow. Worst part is the roadside assistance is useless, they could not find a tow truck to come to my location. I had to call a tow truck myself. Never have had this happen to me before, car is practically brand new. Just very frustrated!!
 

·
Registered
Joined
·
50 Posts
Feel like it's either the battery or the spark plugs. Both of which happened to me in the past with two different cars.
But we'd expect better form Maserati and on a new car no less...

Let us know what your dealership finds.
 

·
Registered
Joined
·
14 Posts
Have you tried turning it off and on again? But in all seriousness that's a ridiculous situation to have to experience in an 8 month old car. Unless you accidentally left something on inside the truck, I doubt it would be the battery. And even if you did, its unlikely it would drain it completely in 15 minutes. I think most likely its a faulty spark plug, but I suppose you know what it was by now.
 
1 - 4 of 4 Posts
Top