Maserati Levante Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
I am trying to determine if my vehicle has an isolated glitch or other have the same issue. Whenever I am trying to park in certain parkades (have not figured out the pattern) the rear parking sensors give a steady tone and the display is red indicating I am going to hit something even if nothing is close. I have a Range Rover that I park in the same spot with no issues. Thanks.
 

·
Registered
Joined
·
1 Posts
I am trying to determine if my vehicle has an isolated glitch or other have the same issue. Whenever I am trying to park in certain parkades (have not figured out the pattern) the rear parking sensors give a steady tone and the display is red indicating I am going to hit something even if nothing is close. I have a Range Rover that I park in the same spot with no issues. Thanks.
Hi, I got exactly the same problem in my parking, when I'm doing a rear left the sensor give me the steady tone and on the display the left indicator is flashing red. It's only when the wether is wet outside and only in my roof covered underground parking.


Did you solve the issue?


Best's.


David
 

·
Registered
Joined
·
7 Posts
If it happens in the garage only, then don't worry it's okay. If you have this issue with parking outside, try to clean your parking sensors. If that won't help, go to your dealer to see what's wrong.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #8 ·
The dealer did an update and it has solved the problem. Having a first model year likely to have some glitches but have to say the Maserati of Alberta has been excellent.
 
1 - 8 of 8 Posts
Top